Compatible with iPhone, iPod Touch and iPad. Requires iOS 4.0 or later.

Compatible with iPhone, iPod Touch and iPad. Requires iOS 4.0 or later.


Compatible with Android 2.3 or higher, requires Adobe AIR 2.6 or higher

Compatible with Microsoft Windows® XP or Higher, Mac® OS X 10.5.8 or Higher, Requires Adobe AIR 2.6 or higher.

Mac OS & Windows PC & Laptop





 

ShreeNathji Darshan on Youtube

Android Mobile & Tablet




or install using the QR Code.

iPhone, iPod Touch, iPad



Download instructions »
or install using the QR Code.
Subscribe Newsletter